[learning]steem区块链机器人开发学习活动(2)-安装必要的依赖库

in hive-180932 •  last month  (edited)

目录:

安装必要的依赖库

1.安装python

本教程基于python 3.7,你也可以自由选择自己喜欢的编程语言,大体差不多。

首先需要安装一个pyhton3.7,可以从官网下载:https://www.python.org

也可以选择安装Anaconda,这是预安装了很多常用库的一个集成。

建议别下载最新的python3.9,因为steem的库有些比较老旧没人更新,可能有些依赖包不好安装,下python3.7就好。

1. 安装beem库

steem有steem和beem等库,steem库有些地方比较老旧没更新,所以建议使用beem库。

建议使用beem,0.24.13版本,因为太旧的有些地方会出错。太新的又过于偏向hive链,steem使用可能会报错。

安装办法:

pip install beem==0.24.13

linux系统安装一般不会报错,windows系统通常会有各种各样奇怪的报错。

windowns安装通常会提醒需要安装Microsoft Visual C++ 14.0等,不想安装可以无视这报错,看看缺哪个依赖库就直接手动下载whl安装。

搜索whl文件可以去这里:https://www.lfd.uci.edu/~gohlke/pythonlibs/

遇到安装问题可以找@abcallen进入steem学院的微信群询问。

章节小结

  • 1.windows安装会遇到各种错误,这是正常的事情,请不要气馁,有问题大胆问就是。

  • 2安装完毕,可以按照beem帮助文档自行摸索一下beem库的功能:https://beem.readthedocs.io/en/latest/

Authors get paid when people like you upvote their post.
If you enjoyed what you read here, create your account today and start earning FREE STEEM!
Sort Order:  
  ·  last month 

beem怎么安装完全看不懂啊~拍

  ·  last month 

先安装python,然后打开cmd,输入pip install beem==0.24.13就可以了(没报错的话)

  ·  last month 

image.png
这样算是安装完成吗?

  ·  last month 

👏👏

等着下一堂课(Window下,就报了一个warning,beempy加$PATH)

  ·  last month 

拍拍魚哥

  ·  last month 

谢谢鱼哥

不是很懂啊,鱼哥。😃

[WhereIn Android] (http://www.wherein.io)

  ·  last month 

可以找@abcallen进steem学院微信群问问

  ·  last month (edited)

谢谢大佬。不知道大佬用的是什么操作系统和集成开发工具

Descarga e instala algún sistema operativo Linux yo te recomendaría que este basado en debían. Otra cosa a tener en cuenta es que existen varios gestores de descarga. En el ejemplo se está usando el de pip. Prueba con este comando.

sudo apt-get install beem==0.24.13

学习了

良好的工作保持它

  ·  22 days ago 

今天开始学。python3.9.5 安装beem成功:

Image 2.jpg